Forums: Rockclimbing.com: Bugs & Error Reports:
"View All" doesn't work?
RSS FeedRSS Feeds for Bugs & Error Reports

Premier Sponsor:

 


mojomonkey


Jan 24, 2011, 6:22 AM
Post #1 of 8 (1974 views)
Shortcut

Registered: Aug 13, 2006
Posts: 854

"View All" doesn't work?
Report this Post
Average: avg_1 avg_2 avg_3 avg_4 avg_5 (0 ratings)  
Quote | Reply

At least for me, clicking on "view all" for a thread does not show all posts in a single page, it just takes me to the first page of the thread.

Also, is there a way to mark all of a thread read? I was trying to do the above to "read" all the posts in an old thread that was bumped up to new again, so it stopped showing up as unread.


jt512


Jan 24, 2011, 2:11 PM
Post #2 of 8 (1952 views)
Shortcut

Registered: Apr 11, 2001
Posts: 21893

Re: [mojomonkey] "View All" doesn't work? [In reply to]
Report this Post
Average: avg_1 avg_2 avg_3 avg_4 avg_5 (0 ratings)  
Quote | Reply

mojomonkey wrote:
At least for me, clicking on "view all" for a thread does not show all posts in a single page, it just takes me to the first page of the thread.

It doesn't work for me either, and I wish it did.

Jay


mojomonkey


Jan 27, 2011, 2:03 PM
Post #3 of 8 (1923 views)
Shortcut

Registered: Aug 13, 2006
Posts: 854

Re: [mojomonkey] "View All" doesn't work? [In reply to]
Report this Post
Average: avg_1 avg_2 avg_3 avg_4 avg_5 (0 ratings)  
Quote | Reply

Can a mod move this to the bugs forum? I accidentally posted it in the wrong place and don't know if those that might actually fix it monitor this forum.


edge


Jan 27, 2011, 2:11 PM
Post #4 of 8 (1921 views)
Shortcut

Registered: Apr 14, 2003
Posts: 9118

Re: [mojomonkey] "View All" doesn't work? [In reply to]
Report this Post
Average: avg_1 avg_2 avg_3 avg_4 avg_5 (0 ratings)  
Quote | Reply

mojomonkey wrote:
Can a mod move this to the bugs forum? I accidentally posted it in the wrong place and don't know if those that might actually fix it monitor this forum.

Done.


ddt


Feb 3, 2011, 7:31 AM
Post #5 of 8 (1886 views)
Shortcut

Registered: May 20, 2005
Posts: 2304

Re: [mojomonkey] "View All" doesn't work? [In reply to]
Report this Post
Average: avg_1 avg_2 avg_3 avg_4 avg_5 (0 ratings)  
Quote | Reply

Yes, it's a bug. I'll fix it within the next few days.


ddt


Feb 8, 2011, 1:39 AM
Post #6 of 8 (1854 views)
Shortcut

Registered: May 20, 2005
Posts: 2304

Re: [mojomonkey] "View All" doesn't work? [In reply to]
Report this Post
Average: avg_1 avg_2 avg_3 avg_4 avg_5 (0 ratings)  
Quote | Reply

OK, it's fixed now.

It will however break in very large threads (with thousands of replies). I'll see if I can find a solution to that...

DDT


ddt


Feb 8, 2011, 2:03 AM
Post #7 of 8 (1848 views)
Shortcut

Registered: May 20, 2005
Posts: 2304

Re: [ddt] "View All" doesn't work? [In reply to]
Report this Post
Average: avg_1 avg_2 avg_3 avg_4 avg_5 (0 ratings)  
Quote | Reply

OK... not the most elegant solution, but I've set a limit to 1000 posts, which prevents breaking in very large threads.


mojomonkey


Feb 8, 2011, 9:49 AM
Post #8 of 8 (1834 views)
Shortcut

Registered: Aug 13, 2006
Posts: 854

Re: [ddt] "View All" doesn't work? [In reply to]
Report this Post
Average: avg_1 avg_2 avg_3 avg_4 avg_5 (0 ratings)  
Quote | Reply

Thanks, good enough for my purposes.


Forums : Rockclimbing.com : Bugs & Error Reports

 


Search for (options)

Log In:

Username:
Password: Remember me:

Go Register
Go Lost Password?



Follow us on Twiter Become a Fan on Facebook