Forums: Rockclimbing.com: Bugs & Error Reports:
Site running like a dog
RSS FeedRSS Feeds for Bugs & Error Reports

Premier Sponsor:

 


Partner cracklover


Jan 28, 2015, 5:45 AM
Post #1 of 9 (4340 views)
Shortcut

Registered: Nov 14, 2002
Posts: 10161

Site running like a dog
Report this Post
Average: avg_1 avg_2 avg_3 avg_4 avg_5 (0 ratings)  
Quote | Reply

Is it just me, or are all the pages taking forever to load?

GO


Partner epoch
Moderator

Jan 28, 2015, 1:44 PM
Post #2 of 9 (4334 views)
Shortcut

Registered: Apr 27, 2005
Posts: 32163

Re: [cracklover] Site running like a dog [In reply to]
Report this Post
Average: avg_1 avg_2 avg_3 avg_4 avg_5 (1 rating)  
Quote | Reply

It's a throwback to the days when the servers ran via hamster.


Partner Jeff
Owner

Jan 28, 2015, 6:46 PM
Post #3 of 9 (4322 views)
Shortcut

 
Re: [epoch] Site running like a dog [In reply to]
Report this Post
Average: avg_1 avg_2 avg_3 avg_4 avg_5 (0 ratings)  
Quote | Reply

Yeah, this new server still needs some tuning. The MySQL database is locking up a bit...

Been working on a few other problems that cropped up post migration, hoping to get to actual server tuning shortly.


Partner cracklover


Feb 3, 2015, 6:04 AM
Post #4 of 9 (4265 views)
Shortcut

Registered: Nov 14, 2002
Posts: 10161

Re: [Jeff] Site running like a dog [In reply to]
Report this Post
Average: avg_1 avg_2 avg_3 avg_4 avg_5 (1 rating)  
Quote | Reply

Seems *much* better now. But the my_topics (?do=my_topics;) still often is not working.

Black header bar -> My Stuff -> My Topics

GO


Partner Jeff
Owner

Feb 6, 2015, 11:47 AM
Post #5 of 9 (4229 views)
Shortcut

 
Re: [cracklover] Site running like a dog [In reply to]
Report this Post
Average: avg_1 avg_2 avg_3 avg_4 avg_5 (0 ratings)  
Quote | Reply

cracklover wrote:
Seems *much* better now. But the my_topics (?do=my_topics;) still often is not working.

Black header bar -> My Stuff -> My Topics

GO

Thanks for the heads up Gabe. I dug a bit deeper and changed a few database cache settings.

Is it better now?


(This post was edited by Jeff on Feb 6, 2015, 11:48 AM)


Partner cracklover


Feb 6, 2015, 3:55 PM
Post #6 of 9 (4219 views)
Shortcut

Registered: Nov 14, 2002
Posts: 10161

Re: [Jeff] Site running like a dog [In reply to]
Report this Post
Average: avg_1 avg_2 avg_3 avg_4 avg_5 (0 ratings)  
Quote | Reply

Jeff wrote:
cracklover wrote:
Seems *much* better now. But the my_topics (?do=my_topics;) still often is not working.

Black header bar -> My Stuff -> My Topics

GO

Thanks for the heads up Gabe. I dug a bit deeper and changed a few database cache settings.

Is it better now?

Yes! Thanks! BTW, I'm also working on tuning a MySQL server. Lots of interesting settings to play with... Kind of fun!

GO


Partner Jeff
Owner

Feb 6, 2015, 4:05 PM
Post #7 of 9 (4213 views)
Shortcut

 
Re: [cracklover] Site running like a dog [In reply to]
Report this Post
Average: avg_1 avg_2 avg_3 avg_4 avg_5 (0 ratings)  
Quote | Reply

You probably already know this, but innodb_buffer_pool_size & innodb_buffer_pool_instances are your friends. I'd completely forgotten when we migrated to change the defaults, that's why the site was slow... buffer pool size of 128MB. It's 20 GB now which should be far more than we need. :-D

Unfortunately, this site has 24 tables that have FULLTEXT indexes, so can't be converted to InnoDB without changing MySQL server version, and I'm hesitant to do that for several reason... those are the likely culprits at this point if any part of the site is running slow.


(This post was edited by Jeff on Feb 6, 2015, 4:05 PM)


Partner cracklover


Feb 8, 2015, 7:29 AM
Post #8 of 9 (4185 views)
Shortcut

Registered: Nov 14, 2002
Posts: 10161

Re: [Jeff] Site running like a dog [In reply to]
Report this Post
Average: avg_1 avg_2 avg_3 avg_4 avg_5 (0 ratings)  
Quote | Reply

Jeff wrote:
You probably already know this, but innodb_buffer_pool_size & innodb_buffer_pool_instances are your friends. I'd completely forgotten when we migrated to change the defaults, that's why the site was slow... buffer pool size of 128MB. It's 20 GB now which should be far more than we need. :-D

Unfortunately, this site has 24 tables that have FULLTEXT indexes, so can't be converted to InnoDB without changing MySQL server version, and I'm hesitant to do that for several reason... those are the likely culprits at this point if any part of the site is running slow.

We should probably take this conversation offline, but two quick thoughts:

1 - Starting with version 5.6 innoDB tables can support Full-Text search. So you should consider moving those from MyISAM. But there are still some reasons to keep some tables in the older engine. If you choose to do so, consider point 2.

- key_buffer_size defines size in memory for index blocks to share from MyISAM tables. The default for this on your DB is 16 M - tiny! If you have some large and vital indexed MyISAM tables consider upping this variable to as much a quarter of the memory available on your machine.

Good luck!

GO


lena_chita
Moderator

Mar 5, 2015, 8:28 AM
Post #9 of 9 (4017 views)
Shortcut

Registered: Jun 27, 2006
Posts: 6087

Re: [cracklover] Site running like a dog [In reply to]
Report this Post
Average: avg_1 avg_2 avg_3 avg_4 avg_5 (1 rating)  
Quote | Reply

It seems to be slower again the last couple days?


Forums : Rockclimbing.com : Bugs & Error Reports

 


Search for (options)

Log In:

Username:
Password: Remember me:

Go Register
Go Lost Password?
$62.96 (10% off)
$13.05 (10% off)
$53.96 (10% off)
$21.56 (10% off)



Follow us on Twiter Become a Fan on Facebook